Partial Platform Outage
Incident Report for cloud.gov
Postmortem
Posted May 01, 2024 - 13:51 EDT

Resolved

Incident Summary:


On 4/7/2024 and 4/8/2024, our platform experienced a Distributed Denial of Service (DDoS) attack that briefly impacted our services. We want to assure our users that the security and reliability of our platform are of utmost importance. Thanks to our robust security measures and platform automation, we were able to fully recover and mitigate the effects of the DDoS attack in under two minutes.

Incident Details:


Time Detected: 4/7/2024 6:30 PM & 4/8/2024 7:45/8:10 PM ET
Duration: Each of the 3 events lasted less then 2 minutes each
Impact: Users may have experienced slow response times to access our services during the attack.
Resolution: Our automated DDoS protection systems quickly identified and mitigated the attack, restoring normal service operations without significant impact.


Actions Taken:


Immediate Mitigation: Our DDoS mitigation tools were activated to filter out malicious traffic, allowing legitimate user traffic to continue unaffected.
Investigation: Our security team is conducting a thorough investigation into the attack to understand its origins and to prevent similar incidents in the future.


Next Steps:


We will continue to monitor our systems closely and adjust our security measures as needed. An in-depth review of this incident is being conducted to identify any potential improvements to our security posture. We will keep our users updated on any relevant developments or preventive measures being implemented.



Acknowledgment:


We appreciate your understanding and patience during this incident. The swift resolution of this DDoS attack underscores our commitment to providing a secure and reliable platform. If you have any concerns or questions, please do not hesitate to contact our support team.



Thank you for your continued trust in cloud.gov




Posted Apr 08, 2024 - 20:00 EDT