Forced upgrade of brokered PostgreSQL RDS instances
Incident Report for cloud.gov
Resolved
This incident has been resolved.
Posted Feb 12, 2021 - 10:57 EST
Update
After conferring with AWS, we’ve discovered that this update does not currently affect our services, and the posting by AWS was made in error. AWS does plan a similar update for the GovCloud regions sometime in the future, but have yet to provide a timeline for this migration.
We still highly recommend updating away from PostgreSQL 9.5 to 9.6 or higher sooner rather than later, as support has ended for 9.5 and this update will be forced in the future.
Posted Feb 12, 2021 - 10:30 EST
Identified
AWS is updating brokered RDS for PostgreSQL instances using PostgreSQL version 9.5 beginning this coming Monday, February 15th, 2021. We are reaching out to AWS and directly to affected customers to try and reduce any unanticipated impacts caused by these upgrades. You can find additional background from AWS here: https://forums.aws.amazon.com/ann.jspa?annID=8176

Prior to this date, the most effective way to ensure that an upgrade to a more recent version of PostgreSQL won’t adversely impact your applications is to upgrade to a newer version in a test environment and ensure your apps work properly. Given the short timeline for the change announced by AWS, this should be done as expeditiously as possible. If you have questions or need assistance with this please reach out to support@cloud.gov.
Posted Feb 10, 2021 - 18:58 EST
This incident affected: cloud.gov customer applications (Service - Relational databases (RDS)).