Unable to provision new instances of Custom Domain and CDN Services
Incident Report for cloud.gov
Resolved
We've updated the Custom Domain Broker to restore access to provision this service.
Posted Jan 31, 2020 - 17:14 EST
Update
We have restored access to the CDN broker as of January 17th. We're continuing work on the Custom Domain Broker, and anticipate it should be available by the end of the week.
Posted Jan 27, 2020 - 17:08 EST
Update
cloud.gov engineers continue efforts to update and restore CDN Broker services; we expect the CDN Broker to be deployed on January 16th. The domain broker should be available to customers during the week of January 20th.
Posted Jan 16, 2020 - 15:24 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 15, 2019 - 16:41 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 08, 2019 - 13:27 EST
Investigating
*Existing instances are unaffected and no action needs to be taken if you have an existing instance.*
We are currently unable to provision new instances of the Custom Domain and CDN services.
We use Let’s Encrypt for generating SSL certificates for these services, and today they’ve deprecated one of the APIs we use when creating new certificates. We are working on a replacement for the existing service broker, but it is not yet production-ready. We anticipate having the new broker ready in the coming week, but in the meantime we have no way to create new instances of these services.
It bears repeating: Current instances of these services are unaffected, and will continue to be unaffected. The API Let’s Encrypt has deprecated is specific to a process we only go through for new service instances.
As always, please reach out if you have any questions or concerns.
Posted Nov 08, 2019 - 12:49 EST
This incident affected: cloud.gov customer applications (Service - CDN (cdn-route), Service - Custom Domain Service).