Email to cloud.gov support may be delayed
Incident Report for cloud.gov
Resolved
This issue is resolved. Since we didn't observe any impact to customer service, we will not be providing further updates.
Posted Nov 01, 2023 - 13:13 EDT
Update
We are receiving email from external domains, but we have not received an "all clear" from GSA IT, so we don't have evidence that the issue is resolved.

What seems most expedient in this case: If your email to support@cloud.gov has not received a response today, please call (redacted) to reach a member of our team.
Posted Nov 01, 2023 - 11:15 EDT
Monitoring
GSA IT has informed us they are working on an issue causing emails from external (non-GSA) senders to be delayed up to several hours before reaching gsa.gov inboxes.

We are currently receiving some email to support@cloud.gov, but we are not able to determine if we are receiving all mail sent to us in a timely manner.

If you've attempted to reach cloud.gov, you may want to try again. If this issue persist for another hour, we will provide alternative means for reaching our support team.
Posted Nov 01, 2023 - 10:12 EDT
This incident affected: Services cloud.gov depends on (GSA Corporate Email).